Opened 5 years ago

Closed 5 years ago

#18493 closed defect (duplicate)

_organizeChildrenManually of GridContainerLite

Reported by: gysheng Owned by:
Priority: undecided Milestone: tbd
Component: DojoX Layout Version: 1.10.2
Keywords: Cc:
Blocked By: Blocking:

Description

When I set isAutoOrganized of GridContainer? to false,I can't add Portlet to last column,for example: var gc1 = new GridContainer?({ title : "门户", nbZones :3, hasResizableColumns : true, isAutoOrganized : false, doLayout : true, acceptTypes : [ "Portlet", "TitlePane?", "ContentPane?", "Calendar" ] }); var tp1 = new dijit.TitlePane?({ attachParent : true,

title : 'Panel 1', dndType : 'TitlePane?'

}); gc1.addChild(tp1,2,0); So I debuged the source of GridContainerLite?. I found a line in _organizeChildrenManually of GridContainerLite?: this._insertChild(child, child.column - 1); It mybe means the column parameter of addChild method of GridContainer? is first=1. but i saw other source,I found the column parameter is frist=0; So i change it to: this._insertChild(child, child.column); then,"gc1.addChild(tp1,2,0);" is OK.

Change History (1)

comment:1 Changed 5 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #18484.

Note: See TracTickets for help on using tickets.