Opened 4 years ago

Closed 4 years ago

#18492 closed defect (invalid)

Unable to create dijit.Tree in DOJO 1.10

Reported by: dnp12078 Owned by: dnp12078
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.10.0
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

I have some issues when creating dijit.Tree components.

mystore = new XMLStringStore({
                    xmlstring: xmlLocal,
                    label: "Workflow Log"
                });

                this.xmlStore = mystore;

                mystore.getLabel = function (item) {
                    var label = mystore.getValue(item, "@workflow-name", null);
                    if (label) {
                        return label;
                    }

                    return mystore.getValue(item, "@name", mystore.getValue(item, "tagName", null));
                };

                treeModel = new ForestStoreModel({
                    jsId: "xmlModel",
                    store: mystore,
                    query: {},
                    childrenAttrs: ["childNodes"],
                    rootLabel: "Workflow Log",
                    deep: 'true'
                });

                // Create the Tree.
                tree = new Tree({
                    model: treeModel,
                    onClick: function (item) {
                        
                    },
                    onOpen: function (item) {
                        
                    },
                    style: "height:100%"
                });

Error: Uncaught TypeError?: Cannot read property 'bubble' of undefined

The error is raised when creating the Tree (it is dijit.Tree) component (when executing tree = new Tree ... ).

Stack Trace:

Uncaught TypeError?: Cannot read property 'bubble' of undefined dojo_Layer.js:2 on.selector dojo_Layer.js:2 on.parse dojo_Layer.js:2 on Tree.js:2 _4.postCreate sppcui_Layer.js:2 dLang.extend._idxWidgetPostCreatesppcui_Layer.js:2 _14e4.createsppcui_Layer.js:2 _104f.createsppcui_Layer.js:2 _14e4.postscriptsppcui_Layer.js:2 (anonymous function) WorkflowLogs?.js:367 dojo.declare._createWidgetsWorkflowLogs.js:172 (anonymous function)dojo_Layer.js:2 _583.(anonymous function)._588sppcui_Layer.js:2

Attachments (1)

dijitTreeError.PNG (23.5 KB) - added by dnp12078 4 years ago.
Stack Trace

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by dnp12078

Attachment: dijitTreeError.PNG added

Stack Trace

comment:1 Changed 4 years ago by bill

Owner: changed from bill to dnp12078
Status: newpending

You'll have to attach an actual test case using the attach file button. I can't reproduce with code snippet above because xmlLocal isn't defined, and the this reference has no meaning. Thanks.

comment:2 Changed 4 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.