Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#18443 closed defect (duplicate)

IE10 on Windows 7 is not detected properly by dojo/has

Reported by: Michael J Van Sickle Owned by:
Priority: low Milestone: 1.11
Component: General Version: 1.10.3
Keywords: Cc:
Blocked By: Blocking:

Description

In order to determine if a browser is IE or not, dojo/sniff checks the navigator.appVersion for the string 'MSIE '. This is not present in IE10 for Windows 7. As a result, no browser is detected.

ref: https://github.com/dojo/dojo/blob/master/sniff.js#L59

For my setup, the applicaton version is: navigator.appVersion = "5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath?.2; MS-RTC LM 8; Zune 4.7; rv:11.0) like Gecko"

Running IE10 on Windows 7 Pro SP1 (64 bit)

Change History (6)

comment:1 Changed 5 years ago by Michael J Van Sickle

sorry: dojo/has should be dojo/sniff

comment:2 Changed 5 years ago by Michael J Van Sickle

Another screw up, its IE11, not IE10

comment:3 Changed 5 years ago by dylan

Milestone: tbd1.11
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

Actually, this is intentional as it is requested by Microsoft.

See details at http://mail.dojotoolkit.org/pipermail/dojo-interest/2013-December/079827.html

comment:4 Changed 5 years ago by Michael J Van Sickle

Okay, then I would propose that this is a documentation bug on dojotoolkit.org. It makes no mention of reporting only IE 10-. Also, would it make sense to have a log message if IE11+ is detected and has("ie") is used? In short, do you think there are better ways to document this than just in release notes?

comment:5 Changed 5 years ago by ben hockey

#18474 is a duplicate of this ticket.

comment:6 Changed 5 years ago by ben hockey

#18532 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.