Opened 13 years ago

Closed 13 years ago

#1844 closed defect (invalid)

An issue with json-rpc error server response.

Reported by: fyrk@… Owned by: Dustin Machi
Priority: high Milestone:
Component: RPC Version: 0.4
Keywords: json rpc error object Cc:
Blocked By: Blocking:

Description

JSON-RPC response returns corrupted data (inner "error" object) to error callback function.

The problem server response data: { "id":1, "version":1, "error" : { "name" : "JSONRPCError", "code" : 123, "message" : "An error occurred parsing the request object.", "error" : { "name" : "JSONError", "message" : "Bad array", "at" : 42, "text" : "some info" } } }

The root of the problem is the use of "new Error" wrapper to response error object

Change History (1)

comment:1 Changed 13 years ago by alex

Resolution: invalid
Status: newclosed

I'm not sure how a bogus JSON-RPC response from your server is a bug in Dojo. Marking invalid unless and until you can provide a test case that shows that this is a Dojo bug.

Note: See TracTickets for help on using tickets.