Opened 5 years ago

Closed 5 years ago

#18430 closed defect (fixed)

[patch][cla] dojox/form/HorizontalRangeSlider - keep min/max consistent when in RTL mode

Reported by: Nick Nisi Owned by: bill
Priority: low Milestone: 1.11
Component: DojoX Form Version: 1.10.3
Keywords: Cc:
Blocked By: Blocking:

Description

Getting the value of a dojox/form/HorizontalRangeSlider returns an array with the order [min, max]. Getting the value of a dojox/form/HorizontalRangeSlider in RTL mode returns an array with the order [max, min]. Getting the value of a dojox/form/VerticalRangeSlider returns an array with the order [max, min].

It would be nice to have consistency in the order of this array, regardless of the type (vertical or horizontal) or the dir setting. However, this would be a breaking change.

Change History (5)

comment:1 Changed 5 years ago by Nick Nisi

comment:2 Changed 5 years ago by dylan

Milestone: tbd1.11
Owner: changed from dante to bill
Priority: undecidedlow
Status: newassigned
Summary: dojox/form/HorizontalRangeSlider - keep min/max consistent when in RTL mode[patch][cla] dojox/form/HorizontalRangeSlider - keep min/max consistent when in RTL mode

Given that it's a dojox widget, I'm less concerned with the changing being breaking, since it fixes an inconsistency.

Bill, do you have an opinion on this?

comment:3 Changed 5 years ago by bill

Oh, I think we should definitely check it in. I was going to, but I just wanted to test it first.

comment:4 Changed 5 years ago by bill

OK, I confirmed with trunk/dojox/form/tests/test_RangeSlider.html?dir=rtl that it fixes the ordering problem. I'll push the change.

comment:5 Changed 5 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 0dc0d46b94de9fcf3c934358d07677a8d6ba423e/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.