Opened 4 years ago

Closed 3 years ago

#18410 closed defect (fixed)

[patch][cla] dojox/charting/plot2d/Indicator `text` node dimensions are incorrect in Firefox when bidi support is added

Reported by: mwistrand Owned by: cjolif
Priority: high Milestone: 1.12
Component: Charting Version: 1.10.3
Keywords: Cc:
Blocked By: Blocking:

Description

When dojo-bidi is set to true, the width applied to the dojox/charting/plot2d/Indicator text node is incorrect. This appears to be the result of a Firefox bug (https://bugzilla.mozilla.org/show_bug.cgi?id=1109860), a reproduction of which can be found at http://jsfiddle.net/mwistrand/aph95n4s/.

Change History (4)

comment:1 Changed 4 years ago by dylan

Component: DojoX DrawingCharting
Owner: changed from Mike Wilcox to Eugene Lazutkin
Priority: undecidedhigh
Summary: dojox/charting/plot2d/Indicator `text` node dimensions are incorrect in Firefox when bidi support is added[patch][cla] dojox/charting/plot2d/Indicator `text` node dimensions are incorrect in Firefox when bidi support is added

comment:2 Changed 4 years ago by dylan

Owner: changed from Eugene Lazutkin to cjolif
Status: newassigned

comment:3 Changed 4 years ago by dylan

Milestone: tbd1.12

comment:4 Changed 3 years ago by dylan

Milestone: 1.131.12
Resolution: fixed
Status: assignedclosed

It looks like the underlying Firefox issue was also fixed, so I think this PR isn't needed any more (at least for any recent version of Firefox). I'm going to close it out for now, but please re-open if there's a remaining edge case that we're not covering.

Note: See TracTickets for help on using tickets.