Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1839 closed defect (fixed)

dojo.widget.Dialog loses ContentPane functionality

Reported by: greggian@… Owned by: liucougar
Priority: high Milestone:
Component: Widgets Version: 0.4
Keywords: Cc:
Blocked By: Blocking:

Description

The dojo.widget.Dialog widget in 0.4 extends dojo.widget.ContentPane? and mixes in dojo.widget.ModalDialogBase?. The dojo.widget.ModalDialogBase? overrides the ContentPane?'s postCreate method and loses all of the functionality provided there. This seems to affect preloading and supplying a handler, since these are the functions performed in the postCreate method.

Could the dojo.widget.Dialog explicitly call both the dojo.widget.ModalDialogBase? and dojo.widget.ContentPane? postCreate methods?

Change History (5)

comment:1 Changed 13 years ago by greggian@…

This error can be easily reproduced by attempting to set the "preload" property to true on a Dialog widget and observing that the content is not in fact preloaded.

comment:2 Changed 13 years ago by bill

Milestone: 0.4.1
Owner: changed from bill to liucougar
Version: 0.4

comment:3 Changed 13 years ago by liucougar

Status: newassigned

comment:4 Changed 13 years ago by liucougar

Resolution: fixed
Status: assignedclosed

(In [6449]) fixes #1839: dojo.widget.Dialog loses ContentPane? functionality

comment:5 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.