Opened 5 years ago

Closed 5 years ago

#18380 closed defect (duplicate)

dijit/form/Select does not expand in an iPad running iOS8.

Reported by: Bucket Owned by:
Priority: undecided Milestone: 1.7.7
Component: Dijit - Form Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

I have a dijit/form/Select widget with several options. When I touch the Select to view the available options, the widget does not expand.

The Select widget is created in a template HTML file:

<div data-dojo-attach-point="mySelect"
     data-dojo-type="dijit/form/Select"
     class="mySelect">
</div>

The available options are added dynamically:

var categories = [
    {value: "Malcolm Reynolds", label: "Mal Reynolds"},
    {value: "Zoe Alleyne Washburne", label: "Zoe Washburne"},
    {value: "Hoban Washburne", label: "Wash"},
    {value: "Inara Serra", label: "Inara Serra"}
];
this.mySelect.addOption(categories);
this.mySelect.addOption({value: "Jayne Cobb", label: "Jayne Cobb"});
this.mySelect.startup();

The widget works fine on a PC in Chrome 39.0, Firefox 31.0, Safari 5.1.7, IE9, IE10, and IE11. The Select widget seemed to work fine when running iOS7 on an iPad, but after upgrading to iOS8, the Select widget no longer works.

Change History (2)

comment:1 Changed 5 years ago by Jason Cheatham

This is probably due to a change in the event normalization code in dojo/on in 1.9.0, where a branch based on feature detection (has("touch-can-modify-event-delegate")) was changed to a browser detection (has("firefox")). A similar problem was observed with DropDownButton?. The change was reverted in 1.9.4.

Last edited 5 years ago by Jason Cheatham (previous) (diff)

comment:2 Changed 5 years ago by bill

Milestone: tbd1.7.7
Resolution: duplicate
Status: newclosed

Duplicate of #18168.

Note: See TracTickets for help on using tickets.