Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#18342 closed defect (fixed)

'contextmenu' event also firing click event on dijit/form/Button in Internet Explorer 10+

Reported by: benbrunton Owned by: bill
Priority: high Milestone: 1.10.5
Component: Dijit Version: 1.10.2
Keywords: Cc:
Blocked By: Blocking:

Description

Example here: http://codepen.io/benbrunton/pen/aszCH

Right clicking causes the left click listener to fire. This seems to be to do with the dojoClick property which is assigned to nodes in dijit/a11yclick (line 90). This property is used in dojo/touch to alter the native touch behaviour.

Change History (6)

comment:1 Changed 5 years ago by dylan

Milestone: tbd1.11
Owner: set to bill
Priority: undecidedhigh
Status: newassigned

comment:3 Changed 5 years ago by bill

Resolution: fixed
Status: assignedclosed

Change pushed in bce517831e71c23f53e51c387f3f7b8bfa00d843.

comment:4 Changed 4 years ago by bill

#18527 is a duplicate of this ticket.

comment:5 Changed 4 years ago by bill

Milestone: 1.111.10.5

Backported to 1.10 in 40012adf7d42cfff8feb34363b48ec83592a441b.

comment:6 Changed 4 years ago by bill

#18709 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.