Opened 5 years ago

Closed 5 years ago

#18312 closed defect (duplicate)

destroyRecursive() doesn't work if Dialog is inside widget

Reported by: dojonovice@… Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.10.1
Keywords: Cc:
Blocked By: Blocking:

Description

If I use template with dialog widget I am not able to destroy it. I must detect dialog inside the widget and destroy it manually. Is it bug or something wrong in my code. If destroyRecursive() is looking only for children, dialog is not detected because it is not a part of this DOM node.

           var id = "widgetID";
              var widget = registry.byId(id);
              if (widget) {
                  widget.dialog.destroyRecursive(); // I must use this statement
                  widget.destroyRecursive();
              }
<div>
    <div data-dojo-attach-point="dialog" data-dojo-type="dijit/Dialog" data-dojo-props="title : 'Title'">
        <div>
            content
        </div>
    </div>
</div>

I want call only widget.destroyRecursive();.

Change History (1)

comment:1 Changed 5 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #3300.
Yes, it's another manifestation of the problem discussed in #3300. I will update that ticket to cover this case too.

Note: See TracTickets for help on using tickets.