Opened 13 years ago

Closed 13 years ago

#1830 closed defect (duplicate)

dojo 0.4 crashes the ie6 under certain conditions

Reported by: werner.punz@… Owned by: alex
Priority: high Milestone: 0.9
Component: General Version: 0.4
Keywords: Cc: alex
Blocked By: Blocking:

Description

This is a hard one, because I am not sure where the problem really is, i assume it is a combination of css and dojo includes which triggers that one:

Following: A site which uses dojo 0.3.1 works, and as soon as it is moved towards dojo 0.4 it crashes the ie6 rendering engine reproducably. I could narrow the problem down to the initial dojo include which is the source of this crash, and I assume it is a weird combination of css and dojo which causes this, anyway this is an indicator that something in the dojo startup in 0.4 triggers a bug in the ie as it seems, because the other browsers are not affected, not even ie7.

Here is the link to the affected page:

The one running on dojo 0.3.1:

The one running on dojo 0.4 and crashing ie6 http://cmsdev.ooevp.at/index.php?id=4633

http://cmsdev.ooevp.at/index.php?id=4584

Note in the 0.4 version there is a javascript error, I already hav dug into it to be able to know that this is not the cause of the problem, the crash happens at the dojo include phase of the rendering!

Change History (3)

comment:1 Changed 13 years ago by alex

Milestone: 0.5
Owner: changed from anonymous to alex
Priority: normalhigh
Status: newassigned

comment:2 Changed 13 years ago by morris

Due to base tag - duplicate of #1991

comment:3 Changed 13 years ago by bill

Cc: alex added
Resolution: duplicate
Status: assignedclosed

Closing as duplicate of #1991 but Alex may want to take ownership of #1991 since he owns this bug?

Note: See TracTickets for help on using tickets.