Opened 5 years ago

Closed 4 years ago

#18267 closed defect (worksforme)

Dijit sliders do not function properly on Android native browsers

Reported by: mawhidby Owned by:
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.8.5
Keywords: Cc:
Blocked By: Blocking:

Description

When using the dijit.form.HorizontalSlider? and dijit.form.VerticalSlider? on the native Android browser, a user can only drag the slider one increment at a time, and must release the slider before being able to drag it again.

I originally found this issue on 1.8.5, but have been able to reproduce the issue on the nightly builds at http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_Slider.html. Issue is reproducible on the Android 4.2 and 4.3 native browsers (do not have a 4.4 device to try and reproduce). On the first slider with the onChange event triggers, you will notice the Slider1 Value will change by a fixed amount, and then you must release and drag again. On Chrome for Android, the sliders work fine, and the slider values update as you drag.

Note that the dojox.mobile.slider functions properly, but the dijit sliders experience the issue reported.

Change History (2)

comment:1 Changed 5 years ago by freddefisk

For info, I can drag all the sliders on the nightly test page with my Android 4.4.2 (CyanogenMod? 11 20140609-SNAPSHOT-M7)

comment:2 Changed 4 years ago by bill

Resolution: worksforme
Status: newclosed

I tested http://download.dojotoolkit.org/release-1.8.5/dojo-release-1.8.5/dijit/tests/form/test_Slider.html against an Android 4.2 emulator and the first slider worked fine for me. Likewise it worked on my Android 4.0.4 phone, although it was tricky to grab it since it was so small (I had to zoom in).

This was using the native browser, not the Chrome app downloadable from the app store.

Note: See TracTickets for help on using tickets.