Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#18261 closed defect (invalid)

dijit/Tooltip - showDelay and duration

Reported by: dojonovice@… Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.10.0
Keywords: Cc:
Blocked By: Blocking:

Description

How to set duration property?

It seems that showDelay property doesn't work. I have a delay after mouseout event if value was set 0 (showDelay : 0).

I am using new Tooltip({}) and Tooltip.show() / Tooltip.hide(); and I need no delay.

Or another question, how can I change colors / create tooltips with different colors. There is only one id but the delay effect breaking CSS color change.

Change History (6)

comment:1 Changed 5 years ago by bill

Resolution: invalid
Status: newclosed

It seems that showDelay property doesn't work. I have a delay after mouseout event...

Sounds like you are confusing show and hide.

Or another question, how can I change colors / create tooltips with different colors. There is only one id but the delay effect breaking CSS color change.

Please post questions to the dojo-interest mailing list.

comment:2 Changed 5 years ago by dojonovice@…

In API is presented showDelay property. Is it for show() and hide()? If yes, 0 do nothing, fx looks like value 400. I am not able to display and show tooltip immediately. When I set showDelay and duration properties to 0 inside module, it works without delay. Is it bug or not? Is there any way how to remove show/hide delay via API? showDelay as Tooltip argument doesn't work.

Last edited 5 years ago by dojonovice@… (previous) (diff)

comment:3 Changed 5 years ago by bill

The delay for showing the tooltip is controlled by the showDelay, the delay for hiding the tooltip is controlled by the hideDelay property.

comment:4 Changed 5 years ago by dojonovice@…

I will create test cases and test it again in both cases new Tooltip({}) and Tooltip.show() / Tooltip.hide() if I am able to apply showDelay and hideDelay via API - if it works for me. Thanks.

comment:5 Changed 5 years ago by dojonovice@…

I tested it fast on this example and it doesn't work as I set directly duration to 0 and showDelay to 0 inside dijit/Tooltip module. Can you test it please if I am wrong or something is wrong in my code?

      new Tooltip({
           duration : 0,
           showDelay : 0,
           hideDelay : 0,
           connectId : [node],
           label : "tooltip Value",
           position : ["below"]
       });

comment:6 Changed 5 years ago by bill

It's unclear what you mean by "it doesn't work". If you attach a full test case using the "attach file" button and then write a comment here listing the expected behavior vs. actual behavior, then I'll take a look.

Note: See TracTickets for help on using tickets.