Opened 5 years ago

Closed 5 years ago

#18258 closed defect (duplicate)

[regression] TimeTextBox: set("value", ...) only responds when Date object's date is the beginning of the epoch

Reported by: tupton Owned by: Terence Kent
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.10.0
Keywords: Cc:
Blocked By: Blocking:

Description

When using a Date object to set a TimeTextBox's value, you need to set the year, month, and date to the beginning of the epoch: 1970-01-01.

This fiddle illustrates the issue clearly; switching the framework to an earlier version of dojo shows that both TimeTextBox instances are populated correctly.

This seems to be somewhat related to the change in #17955.

Change History (4)

comment:1 Changed 5 years ago by bill

Owner: set to Terence Kent
Status: newassigned
Summary: dijit/form/TimeTextBox#setValue only responds when Date object's date is the beginning of the epoch[regression] TimeTextBox: set("value", ...) only responds when Date object's date is the beginning of the epoch

Is it fixed by d38b0bd2e94af706b27aff49779e706b1fb903bf? If not, tkent, can you fix?

comment:2 Changed 5 years ago by Terence Kent

@bill

This is the same issue as #18201

@tupton

This will be fixed in dojo 1.10.1. Between now and when 1.10.1 is released, I also have a drop-in patch you can use (only about 20 lines). See comment 12 in #18201 for a link to that patch in a JSFiddle.

comment:3 Changed 5 years ago by tupton

I'm sorry, I tried to submit a comment to this effect – that I realize that this was a duplicate and I understand that it will be fixed in an upcoming release – but I never actually pressed "submit changes". I apologize for the extra work created here.

And thank you very much for the quick response!

comment:4 Changed 5 years ago by bill

Resolution: duplicate
Status: assignedclosed

Duplicate of #18201.
No worries.

Note: See TracTickets for help on using tickets.