Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#18254 closed defect (fixed)

[regression] dojo/on.selector causes default actions to be cancelled in IE

Reported by: Colin Snover Owned by:
Priority: blocker Milestone: 1.8.7
Component: Events Version: 1.8.6
Keywords: Cc:
Blocked By: Blocking:

Description

return eventTarget && listener.call(eventTarget, event); returns a falsy value when eventTarget isn’t matched, which is passed out of the function and causes the default action to be prevented in old IE.

In other words, this link is not clickable:

<div id="foo"><a href="http://example.com"></div>
<script>
require([ 'dojo/on', function (on) {
  on('foo', '.thisMatchesNothing:click', function () {});
});
</script>

Patch forthcoming.

Change History (3)

comment:1 Changed 5 years ago by Colin Snover

Milestone: 1.7.61.8.7
Resolution: fixed
Status: newclosed
Version: 1.10.01.8.6

e4296a6 master 2bde291 1.10 2fc0590 1.9 0d4fc05 1.8

comment:2 Changed 5 years ago by Colin Snover

Summary: dojo/on.selector causes default actions to be cancelled in IE[regression] dojo/on.selector causes default actions to be cancelled in IE

comment:3 Changed 3 years ago by dylan

#18250 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.