Opened 5 years ago

Closed 5 years ago

#18245 closed defect (invalid)

traceback in StackController if page specifies its own id

Reported by: fbest Owned by: fbest
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

StackController?.js:

240:			var newButton = this.pane2button(page.id);
241:			newButton.set('checked', true);

dijit.layout.TabController?.pane2button()

function (/*String*/ id){
			// summary:
			//		Returns the button corresponding to the pane w/the given id.
			// tags:
			//		protected
			return registry.byId(this.id + "_" + id);
		} StackController.js:72

fix could look like:

return registry.byId(this.id + "_" + id) || registry.byId(id)

Change History (3)

comment:1 Changed 5 years ago by bill

Component: GeneralDijit
Description: modified (diff)
Owner: set to bill

I don't understand what you are trying to say. Probably by "traceback" you mean "exception"? But I have no idea what you mean by "if page specifies its own id".

Please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser (i.e. not PHP, JSP, etc.).

Then, give exact instructions on how to reproduce the problem using your attached test file, including the browser and version to use.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Alternately, you can give instructions on how to reproduce the problem with an existing test case (in the tests/ directory).

Thanks!

comment:2 Changed 5 years ago by bill

Owner: changed from bill to fbest
Status: newpending

comment:3 Changed 5 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.