Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#18220 closed defect (duplicate)

visible range in TimeTextBox is not showing the correct range

Reported by: kenlau Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.10.0
Keywords: Cc:
Blocked By: Blocking:

Description

Visible range in TimeTextBox? is not showing the correct range. The visibleRange properties seem not reacting to the setting. I take a peek at the TimeTextBox?, seems like some logic is missing in 1.10.0.

I attach a test case for you to debug.

If you modify the test case to use prior version of dojo, i.e. 1.8.6., you can see the visible range working properly.

This is also related to defect 18200 I have opened earlier.

Attachments (3)

testcase18220.html (821 bytes) - added by kenlau 5 years ago.
testcase18220-dojo1.8.6.html (819 bytes) - added by kenlau 5 years ago.
testcase18220-dojo1.10.1.html (821 bytes) - added by kenlau 5 years ago.

Download all attachments as: .zip

Change History (12)

Changed 5 years ago by kenlau

Attachment: testcase18220.html added

comment:1 Changed 5 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #18200.

comment:2 Changed 5 years ago by bill

This is also related to defect #18200 I have opened earlier.

OK, let's just cover it with that ticket. There's already a PR to fix it. Thanks for the test case.

comment:3 Changed 5 years ago by kenlau

I don't think the issue of the 'Visible Range' on TimeTextBox? has been fixed. The issue was also reported in #18200 which was marked as 'fixed'.

Please use the attached new test cases with 1.8.6, and with 1.10.1, you should see the correct visible range in 1.8.6, and incorrect (or unbound) visible range in 1.10.x.

Could you please reopen the defect?

Thanks.

Last edited 5 years ago by bill (previous) (diff)

Changed 5 years ago by kenlau

Changed 5 years ago by kenlau

comment:4 Changed 5 years ago by bill

Your test case will fail because it sets visibleRange whereas with the new code it's controlled by pickerMin and pickerMax. This is an API change from the original code but it's basically unavoidable due to the rearchitecture of the TimePicker? dropdown to have a conventional scrollbar rather than up and down arrows.

comment:5 Changed 5 years ago by kenlau

I have tried using the new pickerMin and pickerMax, I don't think it provides the same behaviour/functionality as with visibleRange from before (pre 1.10.x). The new parameters in 1.10.1 set a range of time in the drop down but without scroll bar, while the visibleRange (pre 1.10.x) gives us the visible range of time around the specified time with up and down arrow.

As well, changing from the up and down arrows to scroll bar for picking up time is changing the usability of picking time for our existing customer.

I will have to feed it back to our architect to see the impact with the new changes due to the rearchitecture of the TimePicker? dropdown in 1.10.x.

Thanks.

comment:6 Changed 5 years ago by kenlau

Could you please reopen the defect (or do you need a new defect), after talking with our architect, we still believe that it is an issue with visibleRange. Even the sample in dojo documentation in http://dojotoolkit.org/reference-guide/1.10/dijit/form/TimeTextBox.html is not functioning with visibleRange. You can take a look. The drop down list is too long by default, and if using minPicker, maxPicker, the drop down list don't have the scrollbar to select time beyond the range. Maybe you can update the sample you have in the online document to show us how to make use of the minPicker,maxPicker or whatever so that we could have the similar functionality from pre 1.10.x release for visibleRange .

Thanks a lot.

comment:7 Changed 5 years ago by bill

There's no reason to reopen the defect or to create a new one. As I already told you, visibleRange has been replaced by pickerMin and pickerMax.

It's true the documentation needs to be updated. In the meantime you can just look at the test file, https://github.com/dojo/dijit/blob/master/tests/form/test_TimeTextBox.html#L186. If you want to control the height of the dropdown, use the HasDropDown#maxHeight? property.

comment:8 Changed 5 years ago by kenlau

We still believe visibleRange functionality is not the same by using pickerMin and pcikerMax in 1.10.x. Maybe you can update the online sample later so that we can take look. For now, we can live with the new re-architect dropdown with height property.

Thanks a lot.

comment:9 Changed 5 years ago by bill

Right, maybe I should have said that visibleRange was replaced by the maxHeight property. And yes, I understand that it's not exactly the same thing.

Anyway, I removed visibleRange from the documentation example, in https://github.com/dojo/docs/commit/3713845cd32564d4f95d264e0c22c7d7bfe551bb.

Note: See TracTickets for help on using tickets.