Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1822 closed defect (fixed)

Using subwidgets with widgetsInTemplate fails in Safari 2.0.4

Reported by: guest Owned by: bill
Priority: high Milestone:
Component: Widgets Version: 0.4
Keywords: Cc: liucougar, dylan, alex, Adam Peller
Blocked By: Blocking:

Description

Rendering of subwidgets (using the new widgetsInTemplate property) fails using Safari 2.0.4, the version of Safari currently shipping with OSX.

Open http://archive.dojotoolkit.org/nightly/tests/widget/test_widgetsInTemplate.html using Safari to reproduce.

This appears to be fixed in the latest Webkit nightlies, available here: http://nightly.webkit.org/

Change History (13)

comment:1 Changed 13 years ago by liucougar

someone out there wants to workaround the issue for the "old" safari?

or shall we just leave it as the nightly is already working

comment:2 Changed 13 years ago by dylan

If anything in the core toolkit relies on it, we need to support it. If not, we need to warn people that use it, and add a note to the release notes, and push to 0.5 at which point we can look to maybe find an easy fix.

comment:3 Changed 13 years ago by liucougar

that depends on how you define "core toolkit"

afaik, only dialogs in editor2 make use of this feature

comment:4 Changed 13 years ago by alex

Milestone: 0.4.1
Owner: changed from bill to liucougar

I'm pretty sure we can't punt on this. We're shipping a property that people are relying on and it's not marked experimental. Please fix.

comment:5 Changed 13 years ago by liucougar

as I said, I have no access to safari

someone wants to adopt this?

comment:6 Changed 13 years ago by liucougar

Owner: changed from liucougar to bill

pass to bill

comment:7 Changed 13 years ago by Adam Peller

Cc: liucougar dylan alex added

The "DOM Exception 5" comes from DomWidget?.js in postInitialize(). The call to setAttribute('_isSubWidget') fails, apparently because of the underscore. Renaming these references eliminates the exception, but the subContainer is not found, as this.domNode seems to be pointing at the widget node itself rather than the template. That's as far as I got tonight. Hopefully this will make more sense to someone else.

comment:8 Changed 13 years ago by Adam Peller

Cc: Adam Peller added

comment:9 Changed 13 years ago by bill

that's interesting about the underscore, but as to why this.domNode points to a widget... that's pretty weird. Although maybe it has something to do w/http://article.gmane.org/gmane.comp.web.dojo.devel/3671/match=parse+createcomponentfromscript and also see http://trac.dojotoolkit.org/changeset/4971

comment:10 Changed 13 years ago by Adam Peller

(In [6793]) Fix "DOM Exception 5" on Safari. References #1822

comment:11 Changed 13 years ago by Adam Peller

(In [6794]) Fix "DOM Exception 5" on Safari. References #1822

comment:12 Changed 13 years ago by alex

Resolution: fixed
Status: newclosed

(In [6795]) Safari handles the <xmp> element differently than other browsers. Fixes #1822

comment:13 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.