Opened 5 years ago

Closed 4 years ago

#18216 closed defect (wontfix)

dojox/mobile breaks Label/Element Association on iOS 5/7

Reported by: George Sexton Owned by: Damien Mandrioli
Priority: undecided Milestone: 1.11
Component: DojoX Mobile Version: 1.10.0
Keywords: Cc:
Blocked By: Blocking:

Description

I've built a simple form, and page that loads dojox/mobile and calls dojox/mobile/parse. The form has some radio, and checkbox elements with labels that are associated with them.

Running on iOS 5/7, if you click on the labels to activate the controls, they will not activate. Even worse, clicking directly on the controls does not work either.

There's something about loading dojox/mobile, and parsing the page that really messes up checkbox and radio group controls badly.

Expected Behavior:

Using dojox/mobile should not disable standard HTML controls.

Version Information:

Dojo: 1.10.0 iOS: 7.1.2, and iOS 5.0 Simulator

Attachments (1)

label.html (1.5 KB) - added by George Sexton 5 years ago.
Sample Web Page that Demonstrates the Issue

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by George Sexton

Attachment: label.html added

Sample Web Page that Demonstrates the Issue

comment:1 Changed 5 years ago by George Sexton

I played with this some more. As a work-around, if I set the data-dojo-type attribute to dojox/mobile/RadioButton or dojox/mobile/CheckBox, things are OK. It's kind of ugly because I'm trying to use the same HTML for mobile and non-mobile.

comment:2 Changed 5 years ago by cjolif

Owner: set to Damien Mandrioli
Status: newassigned

comment:3 Changed 5 years ago by dylan

@gsexton, just curious, have you tried using dojo/parser rather than dojox/mobile/parser ?

comment:4 Changed 4 years ago by dylan

Milestone: tbd1.11
Resolution: wontfix
Status: assignedclosed

I believe the answer here is to use dojo/parser instead.

Note: See TracTickets for help on using tickets.