Opened 5 years ago

Closed 4 years ago

#18199 closed defect (duplicate)

Does not load resource file for internationalization when running in Cordova project on Windows 8 platform.

Reported by: Flower Owned by:
Priority: undecided Milestone: 1.11
Component: Internationalization Version: 1.10.0
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

We are trying to prototype the project using Dojo+Cordova. It is working really well on Android and iOS platforms but having an internationalization issue when we run a Windows 8 version. We are targeting tablets. In particular on Windows 8 platform when we run an app in Visual Studio 2013 it does not return the resource file for internationalization.

To be more precise it is returning object in doLoad function in i18n.js but it is empty :-( There is no Root element in the object.

I created the simple app which can be easily used to reproduce the problem. It is attached.

Attachments (2)

index.js (2.4 KB) - added by Flower 5 years ago.
www.zip (81.3 KB) - added by Flower 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by Flower

Attachment: index.js added

Changed 5 years ago by Flower

Attachment: www.zip added

comment:1 Changed 5 years ago by Flower

Unfortunately could not attach the whole project because of size. I attached just archive of www folder. Everything else is standard. Dojo version is 1.10. Cordova is the latest 3.5.0-0.2.6

comment:2 Changed 4 years ago by swiftfoot

I added a comment with my fix over here, works in my local environment, and I would love to get this into the main dojo stream so going forward we get it.

https://bugs.dojotoolkit.org/ticket/17538

comment:3 Changed 4 years ago by dylan

Milestone: tbd1.11
Resolution: duplicate
Status: newclosed

Duplicate of #17538.
Closing in favor of #17538.

Note: See TracTickets for help on using tickets.