Opened 5 years ago

Closed 5 years ago

#18192 closed defect (duplicate)

dojo/dom-construct::toDom does not handle HTML5 tags in Internet Explorer

Reported by: Marcel Lucas Owned by:
Priority: undecided Milestone: tbd
Component: HTML Version: 1.10.0
Keywords: Cc:
Blocked By: Blocking:

Description

As it seems the dojotoolkit doesn't handle the oddities of IE(7/8) when "arbitrary" elements are being added as templateString:

require(["dojo/dom-construct"], function(domConstruct){

  domConstruct.place("<section><h1>Lorem</h1></section>", document.body); 
//creates something like "<h1>Lorem</h1></section><//section>";

});

jQuery seems to deal with it and generates a proper dom - maybe you could have a peek.

Change History (1)

comment:1 Changed 5 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #11808.

Note: See TracTickets for help on using tickets.