Opened 5 years ago

Closed 4 years ago

#18179 closed defect (fixed)

IE11 doesn't load ipad theme

Reported by: davliu Owned by: Adrian Vasiliu
Priority: undecided Milestone: 1.11
Component: DojoX Mobile Version: 1.10.0
Keywords: Cc: Eric Durocher, Adrian Vasiliu
Blocked By: Blocking:

Description

I noticed 1.10 start to support IE11 in dojox/mobile. but the IE11 can't load ipad theme. I checked the network trace, it actually doesn't load compat css files. To reproduce this issue, just access below url from IE11: http://download.dojotoolkit.org/release-1.10.0/dojo-release-1.10.0/dojox/mobile/tests/test_theme-switch.html?theme=iPhone click ipad tab in the top tabbar, you'll see the theme is still iphone theme

switch to use IE10 or chrome to test, it will switch to ipad theme without problem.

This issue also exist in 1.9.3.

Change History (6)

comment:1 Changed 5 years ago by cjolif

#18178 is a duplicate of this ticket.

comment:2 Changed 5 years ago by cjolif

Cc: Eric Durocher Adrian Vasiliu added

seems to me we said Windows Theme was anyway just for Windows (Phone) devices. That said I don't find this info in the doc. edurocher, Adrian, any feedback?

comment:3 Changed 5 years ago by cjolif

Owner: set to Adrian Vasiliu
Status: newassigned

yes Windows theme is just for Windows but here the user is trying to load iPad theme... which should work?

comment:4 Changed 4 years ago by dylan

Milestone: tbd1.11

So it looks like Trident is overriding the user setting with the iphone theme based on:

https://github.com/dojo/dojox/blob/master/mobile/deviceTheme.js#L255-L258

comment:5 Changed 4 years ago by Adrian Vasiliu

At a quick look, I don't see a problem here. In fact, I think this test file is somehow confusing. What you see is what a real app would get *if* the UA would only contain the word "iPhone", "iPad", "Android" etc. because it programmatically loads the theme files passing this word for the UA argument of deviceTheme.loadDeviceTheme(ua). Thus, the test result doesn't reflect the theme choice that is made on a real iPhone or iPad where the UA contains other elements such as OS version number which influence the theme mapping.

Users do get iPhone/iOS7 theme on iPhone devices, and the iPad.css is additionally loaded on iPad devices. That's what really matters IMO.

As side remark, note that recently the theme mapping has been changed such that the iOS7 theme is loaded by default on all desktop browsers just as on iOS7+ phones and tablets. (BTW, the iOS7 theme is not covered by the test; and the iOS7 theme name also adds to the confusion, because nowadays users wouldn't guess iOS7 theme is more recent than the theme called iPhone but would rather think iOS7 is kind of old legacy stuff...).

it actually doesn't load compat css files.

Since Dojo 1.9, compat css files aren't loaded anymore for IE10+. See in the release notes: "Internet Explorer 10 is now supported “natively” (that is, without compatibility code and CSS): since IE10 supports CSS3 transitions, animations and gradients, compatibility mode is disabled for IE10, and Dojo Mobile uses the non-prefixed CSS3 properties supported by IE10 in addition to the webkit-prefixed properties." (https://dojotoolkit.org/reference-guide/1.9/releasenotes/1.9.html#dojox)

Unless I'm missing something, and unless I get objection, I'll close as "works as expected".

Last edited 4 years ago by Adrian Vasiliu (previous) (diff)

comment:6 Changed 4 years ago by Adrian Vasiliu

Resolution: fixed
Status: assignedclosed

Okay, so I'm closing it.

Note: See TracTickets for help on using tickets.