Opened 5 years ago

Closed 5 years ago

#18173 closed defect (invalid)

When configure the dojo Time dijit with a specific pattern, it gives a validation error if I select any time that is less time 1:00 AM, (ex: 0:15 AM, etc)

Reported by: vipham Owned by: vipham
Priority: undecided Milestone: tbd
Component: DojoX Form Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description

The dojo Time dijit gives an invalid validation error if I configure it with a the following time pattern: K:mm a, z The validation error occurs when I select any time before 1:00 AM, like 0:15 or 0:45 AM, etc. The time pattern was documented at this dojo documentation help: http://publib.boulder.ibm.com/infocenter/eglce/v1r0/index.jsp?topic=%2Fcom.ibm.eglce.lr.doc%2Ftopics%2Fregl_core_date_format.html

Change History (2)

comment:1 Changed 5 years ago by bill

Owner: set to vipham
Status: newpending

Dojo doesn't have a "Time dijit". Please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser (i.e. not PHP, JSP, etc.).

Then, give exact instructions on how to reproduce the problem using your attached test file, including the browser and version to use, and what locales/timezones the code fails in.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Alternately, you can give instructions on how to reproduce the problem with an existing test case (in the tests/ directory).

Thanks!

comment:2 Changed 5 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.