Opened 5 years ago

Closed 4 years ago

#18152 closed defect (patchwelcome)

doh.assertTrue(false, [hint of 195 chars on chromium]), failure

Reported by: garan Owned by:
Priority: undecided Milestone: 1.11
Component: TestFramework Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description

I'm including a stand-alone html file (below), which runs and explains the problem.

Description:

I am basicly doing this: doh.assertTrue(fail, hint_195_characters_long);

The failure is that the exception message doesn't display, instead showing: Uncaught object

doh.t.doh.assertTrue (anonymous function) runFactory execModule (anonymous function) guardCheckComplete checkComplete onLoadCallback req.injectUrl.onLoad

It appears to fail when I attempt to trace-into this line of dojo code:

runner.js line 897: throw new doh._AssertFailure("assertTrue('" + condition + "') failed", hint);

Ultimately, this is looks to be a Chromium issue, yet I am mystified as to why this would fail and wonder if Dojo should accommodate this case.

I'm not sure how to reduce the problem to a non-Dojo failure.

Maybe I am missing something obvious.

Hope I'm not wasting your time.

Stand-alone html test file, below the cut.


<html>

<head>

<script type='text/javascript' language='JavaScript?'>

var dojoConfig = {

parseOnLoad: false, async: 1, isDebug: true, locale: 'en-us', tlmSiblingOfDojo: false, baseUrl: '.', packages: [

{name: 'dojo', location: './dojo/dojo-release-1.9.3-src/dojo'}, {name: 'doh', location: './dojo/dojo-release-1.9.3-src/util/doh'}

]

};

</script>

<script src='./dojo/dojo-release-1.9.3-src/dojo/dojo.js'></script>

</head> <body>

<h1>doh.assertTrue(false, hint_of_195_chars_on_chromium), failure</h1> <h2>

Hi Guys.

</h2> <p>

Love your dojo code. In my opinion, you guys have a made a long series of good decisions. I hope to make creating interfaces with Dojo even easier for programmers with a project I hope to release into the wild, fairly soon. I'm just another engineer under the delusion of being able to create something revolutionary. We'll just have to see about that. I'll give you a heads-up when the code is r

Attachments (1)

dohProblem.html (3.0 KB) - added by garan 5 years ago.
Stand-alone html file, describing and running problem.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by garan

Attachment: dohProblem.html added

Stand-alone html file, describing and running problem.

comment:1 in reply to:  description Changed 5 years ago by garan

Replying to garan: [edit: removed inline html code and uploaded file instead]

I'm including a stand-alone html file (attached to ticket), which runs and explains the problem.

Description:

I am basicly doing this: doh.assertTrue(fail, hint_195_characters_long);

The failure is that the exception message doesn't display, instead showing: Uncaught object

doh.t.doh.assertTrue (anonymous function) runFactory execModule (anonymous function) guardCheckComplete checkComplete onLoadCallback req.injectUrl.onLoad

It appears to fail when I attempt to trace-into this line of dojo code:

runner.js line 897: throw new doh._AssertFailure("assertTrue('" + condition + "') failed", hint);

Ultimately, this is looks to be a Chromium issue, yet I am mystified as to why this would fail and wonder if Dojo should accommodate this case.

I'm not sure how to reduce the problem to a non-Dojo failure.

Maybe I am missing something obvious.

Hope I'm not wasting your time.

comment:2 Changed 5 years ago by bill

Resolution: invalid
Status: newclosed

Presumably the problem is that you are trying to reference a variable named hint_of_195_chars_on_chromium that doesn't exist. The parameter is generally a string literal, not a variable name. Probably that's what you were trying to do but you forgot the quotation marks.

comment:3 Changed 5 years ago by freddefisk

I believe the hint_of_195_chars_on_chromium variable was just used to describe the problem. In the attached test case the variable is defined.

comment:4 Changed 5 years ago by bill

Resolution: invalid
Status: closedreopened

Oh, I didn't read to the bottom of the test case. OK, nevermind.

comment:5 Changed 4 years ago by dylan

Milestone: tbd1.11
Resolution: patchwelcome
Status: reopenedclosed

We have moved dojo core to Intern, and the plan is to focus on Intern rather than maintaining DOH. We would accept pull requests for this issue if someone wants to fix it.

Note: See TracTickets for help on using tickets.