Opened 5 years ago

Closed 5 years ago

#18148 closed defect (duplicate)

templateString replacers ${}

Reported by: dojonovice@… Owned by:
Priority: undecided Milestone: tbd
Component: Parser Version: 1.10.0
Keywords: Cc:
Blocked By: Blocking:

Description

I have problem with latest version of Dojo. Template's replacers are not replaced.

e.g.

templateString : "<div id='menu'>${menuTemplate}</div>",

constructor : function(data) {

this.menuTemplate = this.generateMenuItems(data);

},

App with old Dojo versions 1.8 - 1.9.1 works fine, but with new Dojo version displays markup or crash.

Not sure if it is bug of string module http://dojotoolkit.org/reference-guide/1.10/dojo/string.html#dojo-string

or another dojo widget module.

please check it soon, because ${} replacers are important for widgets and need to know if it is bug or how to continue. This feature must work.

Change History (2)

comment:1 Changed 5 years ago by dojonovice@…

You have a captcha bug. Previous ticket was evaluated as a spam. Therefore you have a duplicity ticket.

Last edited 5 years ago by dojonovice@… (previous) (diff)

comment:2 Changed 5 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #18147.

Note: See TracTickets for help on using tickets.