Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#18140 closed defect (fixed)

[regression] dijit/form/DateTextBox: Calendar navigation not working on touch devices

Reported by: xMartin Owned by: bill
Priority: undecided Milestone: 1.10.1
Component: Dijit - Form Version: 1.10.0
Keywords: Cc:
Blocked By: Blocking:

Description

When using touch input (e.g. iOS device) the navigation of months and years of the calendar widget as part of dijit/form/DateTextBox is not working.

Additionally the month drop down list is not working (see #18139.

Attachments (1)

issue-18140-testcase.html (675 bytes) - added by xMartin 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by xMartin

Attachment: issue-18140-testcase.html added

comment:1 Changed 5 years ago by bill

Milestone: tbd1.10.1
Owner: set to bill
Status: newassigned

Good catch. Yes, I can reproduce it also on test_DateTextBox.html

PS: started with e9a09987211acd8b3b59ed2359b4d21fef099913.

Last edited 5 years ago by bill (previous) (diff)

comment:2 Changed 5 years ago by bill

There are actually two bugs here, that somewhat cancel each other out. Specifically, listening for click events in popups is broken, but on(node, a11yclick, ...), or in templates, data-dojo-attach-event="ondijitclick: ..." still works.

The bugs are:

  1. e9a09987211acd8b3b59ed2359b4d21fef099913 calls .preventDefault() on the touchend event, thus preventing the click event. But we actually still need a click event (perhaps synthetically produced), for anyone that is listening for a click. So we should either call .preventDefault() on the click event rather than the touchend (if that works), or we should emit a synthetic click.
  1. the dojo/touch code still fires a synthetic click event even when .preventDefault() was called on the touchend event

Fixing (2) would actually make the problem caused by (1) worse, so need to be careful.

comment:3 Changed 5 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 3df4a0658b2800d1dafa3cb87f95850187a94d39/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:4 Changed 5 years ago by Bill Keese <bill@…>

In 52fbf1f07d680342063f095b8f0f9a9471723716/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 5 years ago by Bill Keese <bill@…>

In d4b8283c5c1cff9397290438165bb57a77a974de/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 Changed 4 years ago by Bill Keese <bill@…>

In cfbb049eac4c89faa5e72ad7121d6f0634585071/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.