Opened 5 years ago

Closed 4 years ago

#18124 closed defect (fixed)

IE11 test_scroll failures

Reported by: haysmark Owned by:
Priority: undecided Milestone: 1.7.7
Component: HTML Version: 1.7.5
Keywords: Cc:
Blocked By: Blocking:

Description

See:

http://archive.dojotoolkit.org/nightly/checkout/dojo/tests/window/test_scroll.html

I've been noticing failures lately in this test. It looks like IE11 thinks it is an older version of IE with respect to some of the required scrolling calculations. At first I thought this was unique to 1.7, but now it seems that the issue is also in recent versions.

Here is the progress I've made on the 1.7 version, which removes ~28 of the failures:

https://github.com/mahays0/dojo/commit/067de64b6ded82dd42467b538ec73416c0d84a78

I'm all for further feature-detection as an alternative, but this code involves some very complicated maneuvering.

Change History (5)

comment:1 Changed 5 years ago by haysmark

Milestone: tbd1.11

comment:3 Changed 5 years ago by bill

Milestone: 1.111.7.6

comment:4 Changed 5 years ago by Colin Snover

Milestone: 1.7.61.7.7

1.7.6 has been released, retargeting all open tickets to next milestone.

comment:5 Changed 4 years ago by dylan

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.