Opened 5 years ago

Closed 5 years ago

#18118 closed defect (invalid)

Dojo memory is not releasing in DIV approach

Reported by: rahul.sharma Owned by: rahul.sharma
Priority: undecided Milestone: tbd
Component: General Version: 1.10.0
Keywords: Cc:
Blocked By: Blocking:

Description

Hi ,

I am working on a POC which has two pages such as :

  1. The Search page is having one enhanced grid and other dojo components like button (view) in DIV -1 and having an empty DIV-2
  1. When user clicks on view button a new view page which has one enhancedgrid and some other dojo components (return button)is loading in the empty DIV-2 on search page and in this case DIV - 1 would be hidden.
  1. When user clicks on return button on view page , it should destroy all the components of DIV-2 , since they are no longer required.

(Attaching one PPT for reference)

I am doing this using destroy method (used recursive) as well but it is not reclaiming the memory which it used at the time of loading.

We are using DOJO - 1.9.

Any help would be appreciated !

Thanks,

Attachments (1)

DIV.pptx (102.5 KB) - added by rahul.sharma 5 years ago.
Problem statement

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by rahul.sharma

Attachment: DIV.pptx added

Problem statement

comment:1 Changed 5 years ago by bill

Owner: set to rahul.sharma
Status: newpending

Please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser (i.e. not PHP, JSP, and definitely not a powerpoint presentation).

Then, give exact instructions on how to reproduce the problem using your attached test file, including the browser and version to use.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Alternately, you can give instructions on how to reproduce the problem with an existing test case (in the tests/ directory).

Thanks!

comment:2 Changed 5 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.