Opened 5 years ago

Closed 3 years ago

#18112 closed enhancement (duplicate)

Improve dojo/router to not require hashes in the URL

Reported by: cbessette Owned by:
Priority: undecided Milestone: 1.11
Component: Core Version: 1.10.0
Keywords: Cc:
Blocked By: Blocking:

Description

Improve dojo/router to not require hashes in the URL. Allow using hashes, but also allow using HTML5 history, and/or other methods (if any other are available). Perhaps do what the graphing tools do by picking which method is best for the browser.

Change History (2)

comment:1 Changed 3 years ago by dylan

Component: GeneralCore

comment:2 Changed 3 years ago by dylan

Milestone: tbd1.11
Resolution: duplicate
Status: newclosed

Duplicate of #13958.
I was thinking of addressing this in #13958, so closing as a duplicate. That said, @cbessette, help is wanted if you're interested in contributing to make this happen!

Note: See TracTickets for help on using tickets.