Opened 6 years ago

Closed 5 years ago

#18070 closed defect (duplicate)

IE11: Richtext has same min-height problem like former IE versions but fix still uses has("ie") as only condition

Reported by: towby Owned by:
Priority: undecided Milestone: tbd
Component: Editor Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description

In Richtext.js:658

The min-height (move/resize handles on LI) IE bugfix uses has("ie") as condition. IE 11 has the same bug so it would be nice if the condition could be extended to:

(!has("ie") && !has("trident") ? "\tli{ min-height:1.2em; }\n" : "")

Attachments (1)

18070.patch (30.6 KB) - added by towby 6 years ago.
18070.patch

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by towby

Attachment: 18070.patch added

18070.patch

comment:1 Changed 6 years ago by towby

The attached patch fixes the condition.

I added a test case in Editor_misc.html named "min-height on LI" and also refactored the test script to AMD loader structure. (some function calls within the test cases still use global dojo object)

comment:2 Changed 5 years ago by bill

Component: DijitEditor

comment:3 Changed 5 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #18240.
Sorry this ticket was ignored, but anyway the problem was fixed in #18240. Also, Editor_misc.html was upgraded to AMD a while ago too.

Note: See TracTickets for help on using tickets.