Opened 6 years ago

Closed 6 years ago

#18021 closed defect (duplicate)

dojox.gantt - IE 8 UI load time issue

Reported by: manju Owned by:
Priority: undecided Milestone: tbd
Component: Dojox Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description

In IE8 Dojo GanttChart? is taking more time to load UI, it freezes. for eg: in below code i have added 2000 task items in the html

<!DOCTYPE html> <html> <head>

<title>Gantt Chart</title> <meta http-equiv="content-type" content="text/html; charset=utf-8" /> <style> @import "http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/gantt/resources/gantt.css";</style> <script src="http://archive.dojotoolkit.org/nightly/dojotoolkit/dojo/dojo.js"

data-dojo-config="async:true, transparentColor: [ 255, 255, 255 ]"></script>

<script >

require([

"dojo/_base/declare","dojo/parser","dojo/query","dojox/gantt/GanttChart","dojox/gantt/GanttProjectItem","dojox/gantt/GanttTaskItem","dojo/dom","dojo/domReady!"

], function(declare, parser, query, GanttChart?, GanttProjectItem?, GanttTaskItem?, dom){

var projectDev = new GanttProjectItem?({

id: 1, name: "Development Project", startDate: new Date(2012, 5, 11)

}); var taskRequirement = new GanttTaskItem?({

id: 1, name: "Requirement", startTime: new Date(2012, 5, 11), duration: 50, percentage: 50, taskOwner: "Jack"

}); var taskDevelopmentDoc = new GanttTaskItem?({

id: 5, name: "Development doc", startTime: new Date(2012, 5, 20), duration: 20, percentage: 10, previousTaskId: "1", taskOwner: "Rock;Jack"

}); projectDev.addTask(taskRequirement); projectDev.addTask(taskAnalysis); projectDev.addTask(taskDesign); projectDev.addTask(taskDetailDesign); projectDev.addTask(taskDevelopmentDoc);

for (var x =1; x <=20; x++) {

var taskDevelopmentTemp = new GanttTaskItem?({

id: x+5, name: "Development doc - " + x, startTime: new Date(2012, 5, 20), duration: 20, percentage: 10, previousTaskId: "1", taskOwner: "Rock;Jack"

}); projectDev.addTask(taskDevelopmentTemp);

}

var ganttChart = new GanttChart?({

readOnly: true, withTaskId: false, height: 400, width: 1200, withResource: true

}, "gantt"); ganttChart.addProject(projectDev); ganttChart.init();

});

</script>

</head> <body class= "claro" >

<div class= "ganttContent" >

<div id = "gantt" > </div>

</div>

</body> </html>

Change History (1)

comment:1 Changed 6 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #18020.

Note: See TracTickets for help on using tickets.