Opened 6 years ago

Closed 6 years ago

#18019 closed defect (duplicate)

DropDownMenu fails on OSX Chrome 35.0.1916.114

Reported by: szerfastt Owned by: bill
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.10.0-beta1
Keywords: Cc:
Blocked By: Blocking:

Description

Was updated to the latest version of Chrome today, 35.0.1916.114, and noticed DropDownMenu? stopped working. Tested and working fine in Safari and FireFox? with no problems.

Steps to reproduce 1)Navigate to _HasDropDown.html unit test. 2)Click on any of the menus.

Defect: Notice none of the menus open up.

Attachments (2)

Screenshot 2014-05-22 13.36.29.gif (93.0 KB) - added by bill 6 years ago.
works for me
Screen Shot 2014-05-22 at 8.01.07 AM.png (119.3 KB) - added by szerfastt 6 years ago.
Test screen and Chrome version.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by bill

works for me

comment:1 Changed 6 years ago by bill

Owner: set to szerfastt
Status: newpending

Hmm, it works for me:

works for me

Any other tips to reproduce?

Changed 6 years ago by szerfastt

Test screen and Chrome version.

comment:2 Changed 6 years ago by szerfastt

Status: pendingnew

Attachment (Screen Shot 2014-05-22 at 8.01.07 AM.png) added by ticket reporter.

comment:3 Changed 6 years ago by szerfastt

Thank you for testing. Still not working for me. I tested from the following URL: http://download.dojotoolkit.org/release-1.10.0-beta1/dojo-release-1.10.0-beta1/dijit/tests/_HasDropDown.html

We have reproduced this on two different Mac's. An interesting note was this worked fine in Chrome on one system which said it was "Up to Date" even with the prior version of Chrome. As soon as we manually upgraded to 35.0.1916.114 it failed. Can you please try from the above URL not sure if that is the same as the trunk you were testing from. Attaching a screen shot from my system.

comment:4 Changed 6 years ago by bill

Owner: changed from szerfastt to bill
Status: newassigned

OK, now it reproduces for me. I'll take a look.

comment:5 Changed 6 years ago by bill

PS: dojo/touch thinks that Chrome35 supports Pointer events, so when dijit/_HasDropDown sets up an event on touch.press, it listens to "pointerdown" rather than "mousedown", and that doesn't seem to work. Will investigate more tomorrow.

comment:6 Changed 6 years ago by bill

Resolution: duplicate
Status: assignedclosed

Duplicate of #17810.
We reopened #17810 to fix this problem so closing this ticket.

Note: See TracTickets for help on using tickets.