Opened 6 years ago

Closed 6 years ago

#18010 closed defect (invalid)

dijit/form/ComboBox does not open the dropdown at first click

Reported by: dario_poggiali Owned by: dario_poggiali
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.8.6
Keywords: Cc:
Blocked By: Blocking:

Description

I have a dijit/form/ComboBox in my GUI but when I click on the down arrow in order to open the dropdown nothing appears. The dropdown is opened only the second time I click on the down arrow.

Remarks:

  • If I move the CombobBox? up in the DOM using the dev tool at a certain level the ComboBox? starts working again... I generally need to move up by three levels in the DOM. It looks like the bug depends on the DOM position of the ComboBox?.
  • If I remove by hand (always with the dev tool inspector) the widgetid attribute of at least three parents (DIV) the ComboBox? starts working again.

Change History (2)

comment:1 Changed 6 years ago by bill

Owner: set to dario_poggiali
Status: newpending

Please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser (i.e. not PHP, JSP, etc.).

Then, give exact instructions on how to reproduce the problem using your attached test file, including the browser and version to use.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Alternately, you can give instructions on how to reproduce the problem with an existing test case (in the tests/ directory).

Thanks!

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.