Opened 5 years ago

Closed 5 years ago

#18000 closed defect (fixed)

dojox/mobile/ComboBox: broken in RTL

Reported by: Adrian Vasiliu Owned by: Adrian Vasiliu
Priority: undecided Milestone: 1.10
Component: DojoX Mobile Version: 1.10.0-beta1
Keywords: Cc:
Blocked By: Blocking:

Description

When configured in RTL, dojox/mobile/ComboBox misbehaves.

How to reproduce:

Run for instance dojox/mobile/tests/bidi/test_ComboBox_rtl.html (on any browser). When opening any combo: "undefined is not a function" (or the like) in the console.

Change History (3)

comment:1 Changed 5 years ago by Adrian Vasiliu

Milestone: tbd1.10
Owner: set to Adrian Vasiliu
Status: newassigned

comment:2 Changed 5 years ago by Adrian Vasiliu

This bug exists since https://github.com/dojo/dojox/commit/d1fc66522d17af4f508cf2fd0aafd14ee780fe57 (#15682).

The problem is that the new module dojox/mobile/bidi/Scrollable calls the method isLeftToRight() which only exists on widgets, while Scrollable is not always mixed into widgets. This is the case of the instance of Scrollable used by dojox/mobile(/bidi)/_ComboBoxMenu (itself used by ComboBox?).

A solution consists in modifying _ComboBoxMenu such that it adds the isLeftToRight() method on the Scrollable object, with an implementation which redirects the call to the instance of combobox menu (which is an widget).

comment:3 Changed 5 years ago by Adrian Vasiliu <vasiliu@…>

Resolution: fixed
Status: assignedclosed

In 1f068c4d076f079d77e717742286c012a3297741/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.