Opened 5 years ago

Closed 4 years ago

#17977 closed enhancement (fixed)

[patch][cla] Tree: don't expand drop target when dropping below the drop target

Reported by: denovichas Owned by: bill
Priority: undecided Milestone: 1.11
Component: Dijit Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description

when drop an item below a other that has children and is collapsed the drop cause the item to be expanded. you can see this behavior with this test case - http://download.dojotoolkit.org/release-1.9.3/dojo-release-1.9.3/dijit/tests/tree/test_Tree_DnD.html

on the demo if you drop cereals so it anchors off of vegetables things are good. but you if you anchor it off of fruit then fruit will open.

Change History (7)

comment:1 Changed 5 years ago by dylan

Owner: set to bill
Status: newassigned
Summary: dijit.tree.dndSource[patch][cla] dijit.tree.dndSource

comment:2 Changed 5 years ago by bill

Summary: [patch][cla] dijit.tree.dndSource[patch][cla] Tree: don't expand drop target on drop
Type: defectenhancement

Hmm, well as it says in the code (right next to the lines that you modified), this behavior is intentional:

 // Expand the target node (if it's currently collapsed) so the user can see
 // where their node was dropped.   In particular since that node is still selected.

See #6239.

I admit though it's not how macs or Windows works.

comment:3 Changed 5 years ago by denovichas

The comment is correct. The problem is it expands a node above the drop and not the node that it was dropped on. It's subtle useability issue.

comment:4 Changed 5 years ago by denovichas

The title on this ticket is no longer correct.

comment:5 Changed 5 years ago by bill

Summary: [patch][cla] Tree: don't expand drop target on drop[patch][cla] Tree: don't expand drop target when dropping below the drop target

comment:6 Changed 4 years ago by bill

Milestone: tbd1.11

comment:7 Changed 4 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In f4ddce2619bccf67903e3ffe04afab2d23e02ee0/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.