Opened 6 years ago

Closed 6 years ago

#17939 closed defect (duplicate)

dialog fails to appear and js error ie8 ie9 quirksmode when dialog height greater than viewport

Reported by: Larry Chu Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.9.2
Keywords: Cc:
Blocked By: Blocking:

Description

Opening new ticket and attaching test case as requested. In this test case, if the browser starts with a viewport of less than 1000px, then clicking the show button does not show the dialog.

This example is strikingly similar to the example featured in the dojo documentation, the main difference being that I am specifying the height in the style attribute rather than the width.

Attachments (1)

dialog-width-error.html (580 bytes) - added by Larry Chu 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by Larry Chu

Attachment: dialog-width-error.html added

comment:1 Changed 6 years ago by bill

Component: GeneralDijit
Resolution: duplicate
Status: newclosed

Duplicate of #17657.
> Opening new ticket and attaching test case as requested.

My comment #17657 about opening a new ticket was to @ehood, not to you. @ehood claims that he has a case that fails even though he isn't setting the height in the Dialog.

This example is strikingly similar to the example featured in the dojo documentation, the main difference being that I am specifying the height in the style attribute rather than the width.

As I wrote in #17657, you shouldn't be specifying a height to the Dialog like that. When necessary, Dialog will resize itself to fit within the viewport, and you are interfering with that functionality. If you want to set a preferred size you can set it on a <div> inside the Dialog, like

<div data-dojo-type=dijit/Dialog>
    <div style="height: 800px;">
         ...
    </div>
</div>

Sounds like the documentation needs to be updated though.

Note: See TracTickets for help on using tickets.