Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#17912 closed defect (fixed)

Broken link in 1.9 "Making Functions with hitch and partial" tutorial.

Reported by: cbessette Owned by: dylan
Priority: undecided Milestone: 1.10
Component: Documentation Version: 1.9.3
Keywords: Cc: lee
Blocked By: Blocking:

Description

On this page: http://dojotoolkit.org/documentation/tutorials/1.9/hitch/

Near the end, in the section titled "Getting the best of hitch and partial together," in the yellow alert box text there is a link for "dojox/lang/functional" which goes to http://dojotoolkit.org/api/1.9/dojox/lang/functional/ This page gives a 403 access forbidden error.

Change History (6)

comment:1 Changed 5 years ago by bill

Owner: set to dylan
Status: newassigned

comment:2 Changed 5 years ago by dylan

I can fix this, though it looks like every permalink of the following form is broken:

e.g. /api/1.9/dojox/lang/functional/ needs to become /api/?qs=1.9/dojox/lang/functional and /api/1.9/dojo/_base/lang#hitch need to become api/?qs=1.9/dojo/_base/lang#hitch

@bill, is this correct? If so, this means a lot of links are broken.

comment:3 Changed 5 years ago by bill

Hmm, I thought both of them worked.

comment:4 Changed 5 years ago by bill

Cc: rchady added

OK, the issue is really that you are linking to the functional/ directory rather than the functional.html file. If you link to http://dojotoolkit.org/api/1.9/dojox/lang/functional.html it works fine.

Maybe the website should be changed to automatically append .html (if no extension is specified). Note that this limitation isn't restricted to the API doc. For example, https://dojotoolkit.org/reference-guide/1.9/dojo/index.html works but https://dojotoolkit.org/reference-guide/1.9/dojo/index doesn't.

comment:5 Changed 5 years ago by dylan

Milestone: tbd1.10
Resolution: fixed
Status: assignedclosed

While I understand the point you're making, the issue is that this is the URL format that used to be supported (and was even the format generated by the permalink feature of the API viewer). Anyway, I fixed the links in this tutorial for now to work with the newer permalink format.

comment:6 Changed 5 years ago by bill

Cc: lee added; rchady removed

Fair point, well @lbod said he'll update the .htaccess file to fix the permalinks (see https://github.com/lbod/dapi/issues/47), so maybe he can address this too.

Note: See TracTickets for help on using tickets.