Opened 13 years ago

Closed 7 years ago

#1790 closed enhancement (duplicate)

topics enhancement: parent/child topics

Reported by: dylan Owned by: dylan
Priority: high Milestone: future
Component: Events Version: 0.4
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

With topics, it would be highly useful if you could do something like this:

dojo.event.topic.subscribe("foo/bar", ...)

and have it receive topics from:

dojo.event.topic.publish("foo/bar", ...) dojo.event.topic.publish("foo/bar/baz/", ...) dojo.event.topic.publish("foo/bar/zzy", ...) dojo.event.topic.publish("foo/bar/baz/xxy", ...)

And with this enhancement, it would be useful if the subscriber knew the full url/xpath style name of the topic published to.

Change History (5)

comment:1 Changed 12 years ago by Adam Peller

Milestone: 1.0

FWIW, the OpenAjax? hub has this feature. Should we try to leverage it?

comment:2 Changed 11 years ago by dylan

Milestone: 1.3

comment:3 Changed 10 years ago by bill

Description: modified (diff)
Milestone: 1.3future

move unowned / abandoned tickets to "future" milestone

comment:4 Changed 8 years ago by Chris Mitchell

Owner: changed from alex to dylan

comment:5 Changed 7 years ago by dylan

Resolution: duplicate
Status: newclosed

Duplicate of #6385

Note: See TracTickets for help on using tickets.