Opened 6 years ago

Closed 4 years ago

#17871 closed defect (wontfix)

Dojo1.9.3 can not recognize IE 11 by dojo.isIE, it return undefined

Reported by: RickyShi Owned by:
Priority: undecided Milestone: 1.11
Component: Core Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description

If we set the IE document mode to edge, dojo.isIE doens't work.

It caused by IE11 change to use trident.*rv: to represent the version.

Change History (2)

comment:1 Changed 6 years ago by dylan

This is intentional. Please see full details at http://mail.dojotoolkit.org/pipermail/dojo-interest/2013-December/079827.html

Microsoft highly recommends not calling IE11 IE, because it behaves more like other browsers on the market than IE. If you really want to do a browser sniff, use has("trident").

The dojo.is* approach is pre-AMD legacy work and is deprecated.

comment:2 Changed 4 years ago by dylan

Milestone: tbd1.11
Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.