Opened 5 years ago

Closed 5 years ago

#17840 closed defect (fixed)

[Dijit/Android] DOH form fails

Reported by: Sebastien Pereira Owned by: bill
Priority: undecided Milestone: 1.10
Component: Dijit - Form Version: 1.9.3
Keywords: Cc: Patrick Ruzand
Blocked By: Blocking:

Description

Context

  • DOH test
    • dijit/tests/Tooltip-placement.html - test14
  • Reported on:
    • Android 4.2.2 stock browser (Galaxy Tab3 7")

1. dijit/tests/form/Form.html - general tests:getValues

_AssertFailure: assertEqual() failed:

expected {"foo":{"bar":{"baz":{"quux":"2007-12-30T00:00:00.000Z"}}},"available":{"from":"2005-01-02T00:00:00.000Z","to":"2006-01-02T00:00:00.000Z"},"plop":{"combo":"one"},"cb":["2","3"],"r":"2","ms1":["VA","WA"],"s1":"VA","h1":"hidden","t1":"line 1\nline 2","st1":"simple line 1\nsimple line 2","richtext":"<h1>original</h1><p>This is the default content</p>","filename":"","requiredWidget":"","readOnlyWidget":"Should be returned","duplicate":["first","second","third"]} 
but got  {"foo":{"bar":{"baz":{"quux":"2007-12-30T00:00:00.000Z"}}},"available":{"from":"2005-01-02T00:00:00.000Z","to":"2006-01-02T00:00:00.000Z"},"plop":{"combo":"one"},"cb":["2","3"],"r":"2","ms1":["VA"],"s1":"VA","h1":"hidden","t1":"line 1\nline 2","st1":"simple line 1\nsimple line 2","richtext":"<h1>original</h1><p>This is the default content</p>","filename":"","requiredWidget":"","readOnlyWidget":"Should be returned","duplicate":["first","second","third"]}

ERROR IN: https://github.com/dojo/dijit/blob/master/tests/form/Form.html#L204


2. dijit/tests/form/Form.html - general tests:testSubmit

FAILED test: ../../dijit/tests/form/Form.html::general tests::getValues 86 ms _AssertFailure: assertEqual() failed: expected VA,WA but got VA

ERROR IN: https://github.com/dojo/dijit/blob/master/tests/form/Form.html#L216


3. dijit/tests/form/Form.html - general tests:resetTest _AssertFailure: assertEqual() failed:

expected {"foo":{"bar":{"baz":{"quux":"2007-12-30T00:00:00.000Z"}}},"available":{"from":"2005-01-02T00:00:00.000Z","to":"2006-01-02T00:00:00.000Z"},"plop":{"combo":"one"},"cb":["2","3"],"r":"2","ms1":["VA","WA"],"s1":"VA","h1":"hidden","t1":"line 1\nline 2","st1":"simple line 1\nsimple line 2","richtext":"<h1>original</h1><p>This is the default content</p>","filename":"","requiredWidget":"","readOnlyWidget":"Should be returned","duplicate":["first","second","third"]} 
but got  {"foo":{"bar":{"baz":{"quux":"2007-12-30T00:00:00.000Z"}}},"available":{"from":"2005-01-02T00:00:00.000Z","to":"2006-01-02T00:00:00.000Z"},"plop":{"combo":"one"},"cb":["2","3"],"r":"2","ms1":["VA"],"s1":"VA","h1":"hidden","t1":"line 1\nline 2","st1":"simple line 1\nsimple line 2","richtext":"<h1>original</h1><p>This is the default content</p>","filename":"","requiredWidget":"","readOnlyWidget":"Should be returned","duplicate":["first","second","third"]}

with hint: onReset true

ERROR IN: https://github.com/dojo/dijit/blob/master/tests/form/Form.html#L256

Change History (3)

comment:1 Changed 5 years ago by Sebastien Pereira

Cc: Patrick Ruzand added
Milestone: tbd1.10
Owner: set to bill
Status: newassigned

comment:2 Changed 5 years ago by bill

There are two Android bugs uncovered by this regression failure:

  1. Setting multiple=true on a <select multiple> will clear all but the first selected value on Android < 4.4. I'll workaround this. No bug filed since it's fixed in the latest Android.
  1. Programatically deselecting an option in a <select multiple> will select another (filed https://code.google.com/p/android/issues/detail?id=68285)
Last edited 5 years ago by bill (previous) (diff)

comment:3 Changed 5 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 24f696db4230e135df5318ccf1469bb513b46afb/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.