Opened 6 years ago

Closed 6 years ago

#17838 closed defect (fixed)

[Dijit/Android] DOH WidgetsInTemplateMixin fails with TypeError: Object #<HTMLElement> has no method 'click'

Reported by: Sebastien Pereira Owned by: bill
Priority: undecided Milestone: 1.10
Component: Dijit Version: 1.9.3
Keywords: Cc: Patrick Ruzand
Blocked By: Blocking:

Description

  • Context
    • DOH test
      • dijit/tests/_WidgetsInTemplateMixin.html - createAttachWidgetsCombo
    • Reported on:
      • Android 4.2.2 stock browser (Galaxy Tab3 7")

Test fails with TypeError?: Object #<HTMLElement> has no method 'click'

line 239: https://github.com/dojo/dijit/blob/master/tests/_WidgetsInTemplateMixin.html#L239

If I put alert(myawc.mybutton.focusNode.tagName + " / " + !!(myawc.mybutton.focusNode.click));

the result is => SPAN / false

Change History (4)

comment:1 Changed 6 years ago by Sebastien Pereira

Cc: Patrick Ruzand added
Milestone: tbd1.10
Owner: set to bill
Status: newassigned

comment:2 Changed 6 years ago by bill

OK... but it's working against 4.4 for you? Because it works against 4.4 for me.

comment:3 Changed 6 years ago by bill

PS: I did reproduce on 4.2 on Saucelabs, see https://saucelabs.com/tests/e0c7965b3b7943d085347c5e29384814.

comment:4 Changed 6 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In ab269aad9acf1c4c289e382acb019ef4ab155e4f/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.