Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#17835 closed defect (fixed)

dojo gantt chart - last month year number is not proper

Reported by: manju Owned by: JayZ(zhouxiang)
Priority: undecided Milestone: 1.8.7
Component: Dojox Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description

Dojo gantt chart

  • last month displaying with next years date (December 2012 showing as December 2013)
  • year number is not matching with current year number.

Change History (9)

comment:1 Changed 6 years ago by bill

Component: GeneralDojox
Owner: set to JayZ(zhouxiang)
Status: newassigned

comment:2 Changed 6 years ago by freddefisk

The issus seems to be in https://github.com/dojo/dojox/blob/1.9.3/gantt/GanttChart.js#L782 and https://github.com/dojo/dojox/blob/1.9.3/gantt/GanttChart.js#L851 (copy of same code), where it loops through the days and checks if it's a new month. If it is, a new month column is created.

The problem is that when the month changes from December to January, the year will also change, so the code lastYear = date.getFullYear(); will give you the wrong year.

comment:3 Changed 5 years ago by manju

please let me know the fix for it

comment:4 Changed 5 years ago by Nicola Rizzo <nicola.rizzo@…>

Resolution: fixed
Status: assignedclosed

In 9b15b3f1dbdd34b27acaffdd38dce864e1e3ecfd/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 5 years ago by Nicola Rizzo <nicola.rizzo@…>

In 76c7301f8a433fcb5082e0c323926e28978d8904/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 Changed 5 years ago by Nicola Rizzo <nicola.rizzo@…>

In 9f955cad0c479f63fc2c57b54e24df89d46180ca/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:7 Changed 5 years ago by Nicola Rizzo <nicola.rizzo@…>

In cccaf2c96896789be461ecb3c9bfdbee10c5f6dd/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:8 Changed 5 years ago by bill

Please set milestone to earliest version fixed.

comment:9 Changed 5 years ago by nic

Milestone: tbd1.8.7

Fixed and backported through 1.8.x

Note: See TracTickets for help on using tickets.