Opened 5 years ago

Closed 5 years ago

#17831 closed defect (invalid)

dnd in dijit/Tree not working properly on IE8

Reported by: hesamfaraji Owned by: hesamfaraji
Priority: undecided Milestone: tbd
Component: DnD Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description

I have created a simple dijit/Tree with dijit/tree/dndSource as dndController. dnd works perfect across all browsers except IE8. check this fiddle and try to dnd different nodes multiple times: http://jsfiddle.net/Bu9zv/21/

Attachments (2)

test-tree-dnd.html (2.9 KB) - added by hesamfaraji 5 years ago.
Test this file in IE8
test-results.txt (60.1 KB) - added by hesamfaraji 5 years ago.

Download all attachments as: .zip

Change History (12)

Changed 5 years ago by hesamfaraji

Attachment: test-tree-dnd.html added

Test this file in IE8

comment:1 Changed 5 years ago by hesamfaraji

====>please test using attached file instead jsfiddle.<====

comment:2 Changed 5 years ago by bill

Are you having problems changing a node's parent, or is it just a problem trying to change the order of a given parent's children?

comment:3 Changed 5 years ago by hesamfaraji

Last edited 5 years ago by hesamfaraji (previous) (diff)

comment:4 in reply to:  2 Changed 5 years ago by hesamfaraji

the problem is only about changing a node's parent. when i drag a child to a different parent often a red circle comes up telling drag is invalid. but it is not! if i try this multiple times a green bar wins and drop gets completed. in fact dnd is not deterministic in IE8.

Replying to bill:

Are you having problems changing a node's parent, or is it just a problem trying to change the order of a given parent's children?

comment:5 Changed 5 years ago by hesamfaraji

you can also test this problem in dojo/dijit/tests/tree/test_Tree_DnD.html use the tree on the right. dnd multiple times.

comment:6 Changed 5 years ago by bill

Hmm, so test_Tree_DnD.html is also failing for you? Our automated regression test passes on IE8 consistently.

comment:7 in reply to:  6 Changed 5 years ago by hesamfaraji

take a look at my test results file. some of dnd tests have been failed.

Replying to bill:

Hmm, so test_Tree_DnD.html is also failing for you? Our automated regression test passes on IE8 consistently.

Changed 5 years ago by hesamfaraji

Attachment: test-results.txt added

comment:8 Changed 5 years ago by hesamfaraji

disambiguation: the test-tree-dnd.html​ i have attached is NOT the same as dojo/dijit/tests/tree/test_Tree_DnD.html. the names are accidentally the same.

comment:9 Changed 5 years ago by bill

Owner: set to hesamfaraji
Status: newpending

OK. Well, I tried your attached test case in IE8 and it's working pretty well for me. I think I saw something weird one time but I couldn't reproduce it. If you give exact instructions about what to drag where, then I'll try it again.

Also, note that this may have already been fixed. You might want to try your fiddle against Dojo Nightly (selecting it from the dropdown on the left) and see if it still reproduces for you.

comment:10 Changed 5 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.