Opened 6 years ago

Closed 5 years ago

#17816 closed defect (fixed)

Menu: clicking MenuItem focuses <input> behind it (iOS 6.0.3) (iPad mini)

Reported by: Sebastien Brunot Owned by: bill
Priority: undecided Milestone: 1.10
Component: Dijit Version:
Keywords: Cc:
Blocked By: Blocking:

Description

Using the master branch of dijit to test on an iOS 6.0.3 Ipad mini, I found the following issues with test page test_Menu.html:

  • click "Edit -> Paste (Ctrl + V)": the focus is given to the input field that is under the displayed menu item.

Attachments (1)

popup-ios-bug.html (1.6 KB) - added by bill 5 years ago.
updated test case w/checks for unwanted activation of <input>, <button>, and <div>

Download all attachments as: .zip

Change History (8)

comment:1 Changed 5 years ago by bill

Summary: dijit Menu issues on iOS 6.0.3 (iPad mini)Menu: clicking MenuItem focuses <input> behind it (iOS 6.0.3) (iPad mini)

I've seen this before and it's a serious problem but I didn't see a fix. I'll double check using a background iframe, but IIRC it doesn't help.

comment:2 Changed 5 years ago by bill

Milestone: tbd1.10
Owner: set to bill
Status: newassigned

Background iframes don't help, but I can prevent the problem with an evt.preventDefault() on the touchstart event. Note that evt.preventDefault() on the click event doesn't help either.

comment:3 Changed 5 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In e9a09987211acd8b3b59ed2359b4d21fef099913/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:4 Changed 5 years ago by Bill Keese <bill@…>

In 7efe39728726534c59abc5e82afcff4e3c1ade8c/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 5 years ago by bill

#18027 is a duplicate of this ticket.

comment:6 Changed 5 years ago by bill

Resolution: fixed
Status: closedreopened

Reopening since this breaks scrolling (in popups).

Changed 5 years ago by bill

Attachment: popup-ios-bug.html added

updated test case w/checks for unwanted activation of <input>, <button>, and <div>

comment:7 Changed 5 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: reopenedclosed

In af2b3c2d13a83aaf0a217eac99e674a1ae253f96/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.