Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#17813 closed defect (fixed)

[regression] TouchIndicator is slower in 1.9 than 1.8 and indicator drawing might not disappear when touch is release

Reported by: cjolif Owned by: Christophe Jolif <cjolif@…>
Priority: undecided Milestone: 1.9.4
Component: Charting Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description

The commit that introduced this is when TouchIndicator? was changed from using native touch events to use dojo/touch.

The problem has two origins:

  • dojo/touch is slower than native events for some reasons (apparently because firing custom events)
  • dojo/touch target of the release event is the element below touch when releasing while native even still use the element the touch action originating from

Change History (4)

comment:1 Changed 5 years ago by cjolif

For now the fix will consist in being back using native events when possible.

comment:2 Changed 5 years ago by Christophe Jolif <cjolif@…>

Owner: set to Christophe Jolif <cjolif@…>
Resolution: fixed
Status: newclosed

In 57ff714697936c3015edeef9d30ef12ec8336bae/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:3 Changed 5 years ago by Christophe Jolif <cjolif@…>

In 4b556165859afaa92f670df81945731767707ac5/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:4 Changed 5 years ago by cjolif

Milestone: tbd1.9.4
Note: See TracTickets for help on using tickets.