Opened 6 years ago

Closed 6 years ago

#17792 closed defect (invalid)

API Viewer Tree collapses instead of expanding when + clicked in dijit tree

Reported by: kbenjamin Owned by: kbenjamin
Priority: undecided Milestone: tbd
Component: Documentation Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description

In the API Viewer on dojotoolkit.org when you click the + symbol to expand certain tree elements in 'dijit' the entire tree collapses instead of expanding.

Affects API Viewer for versions 1.8 & 1.9.

How to reproduce:

  1. Open the API Viewer: http://dojotoolkit.org/api/
  2. Click 'dijit' (either the word or the + symbol)
  3. Click the + symbol on 'form', 'layout', or 'tree'

Scenarios when it doesn't fail:

  1. When you click on the word instead of the + symbol
  2. When the name of the tree folder is prefixed with _ i.e. '_base'
  3. After you've successfully expanded one of the problem tree elements at least once
  4. In dojo, dojox, or doh trees

My guess is there is some bad bit of code in the 'dijit' tree that occurs after the _xxxx prefixed elements.

Change History (2)

comment:1 Changed 6 years ago by bill

Owner: set to kbenjamin
Status: newpending

I tried this on mac/chrome and mac/firefox, and it works fine. Where does it fail for you?

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.