Opened 6 years ago

Closed 6 years ago

#17785 closed defect (worksforme)

sitepen dgrid inside dojo tabContainer

Reported by: ctsdjgdg Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.9.2
Keywords: Cc:
Blocked By: Blocking:

Description

Issue happens under IE8 only (Works in IE8+ and in chrome). Creating whole page programmatically. Steps as follows.

  1. Creating a content pane
  2. Adding tabContainer with one tab
  3. Calling startup of tabcontainer.
  4. Create dgrid(sitepen's) -> var grid = new declare([ OnDemandGrid?,

Selection,DijitRegistry?])

  1. Populate Grid. Grid.startup() is not needed may be due to step 6.
  2. startup contentpane and resize the contentpane.

The above setup works initially. But when I try to resize window or do something that affects the page resize the whole window goes blank. If I do not create grid, then the page works. So my wild guess is that the issue may be related to dGrid inside tabContainer.

Change History (2)

comment:1 Changed 6 years ago by jmorrin

I cannot reproduce this issue.

Steps taken:

  • I started with the dgrid test page ( dgrid/test/dijit_layout_programmatic.html ).
  • I resized IE8 and everything rendered as expected.
  • I also modified the test page to use a content pane and couldn't reproduce the problem.

comment:2 Changed 6 years ago by bill

Resolution: worksforme
Status: newclosed

OK, I'm closing this. If you can come up w/a reproducible test case then you should file a ticket at https://github.com/SitePen/dgrid/issues.

Note: See TracTickets for help on using tickets.