Opened 6 years ago

Closed 5 years ago

#17779 closed defect (duplicate)

Dijit Dialog show/hide does not always return a promise (Reversion?)

Reported by: spaquette Owned by: spaquette
Priority: undecided Milestone: 1.10
Component: Dijit Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description

This was previously reported in #17100 and closed as fixed, but appears to be back. I couldn't find a reason it might have been reverted.

As per the original ticket, if for any reason the Dialog has already been set to open/!open, no promise is returned and then will fail.

Attachments (1)

index-dialogtest.html (2.4 KB) - added by spaquette 6 years ago.
Test for Dialog.show() and hide() returning null on subsequent calls

Download all attachments as: .zip

Change History (4)

comment:1 Changed 6 years ago by bill

Owner: set to spaquette
Status: newpending

Hmm, it's hard to believe the problem is back since #17100 has an automated test. Please attach a test case demonstrating the problem (using the attach file button).

Last edited 6 years ago by bill (previous) (diff)

Changed 6 years ago by spaquette

Attachment: index-dialogtest.html added

Test for Dialog.show() and hide() returning null on subsequent calls

comment:2 Changed 6 years ago by spaquette

Status: pendingnew

Attachment (index-dialogtest.html) added by ticket reporter.

comment:3 Changed 5 years ago by bill

Milestone: tbd1.10
Resolution: duplicate
Status: newclosed

Duplicate of #17100.
Fixed in 8cbe1a44b75e564bb9a0f4931bf6f26e0ac16b00.

Note: See TracTickets for help on using tickets.