Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17766 closed defect (fixed)

CheckBoxMenuitem: no response if SPACE key pressed too often

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.9.4
Component: Dijit Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Description:

  1. Open dijit.menu test page http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/test_Menu.html in FireFox?.
  2. Focus on the checkbox in 'Navigation menu" using keyboard.
  3. Press SPACE key to operate it, changing its "checked" status.
  4. Try to speed up pressing SPACE key.
  5. The status of checkbox doesn't change if press SPACE key too often.

This issue happens in FireFox?(ESR 17 and v23) This issue doesn't happen on dijit/form/Checkbox.

Change History (4)

comment:1 Changed 6 years ago by bill

Description: modified (diff)
Milestone: tbd1.9.4
Owner: set to bill
Status: newassigned

The problem is in _KeyNavMixin. The first keypress events start a keyboard search, and then for subsequent keydown events, _KeyNavMixin calls evt.stopImmediatePropagation(), preventing a11click.js from seeing the click.

The space key shouldn't start a keyboard search. It would be OK to interpret SPACE as the continuation of a keyboard search, but it shouldn't start one.

comment:2 Changed 6 years ago by bill

Note the stopImmediatePropagation() call came from 8ff1738b5e36c1541f92d5c0e58766264f65895a, see #16925. The Select test is expecting searches containing spaces (but not starting with spaces) to work.

comment:3 Changed 6 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In d641c3fc801a582e7517d9a478152e54f331f52b/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:3 Changed 6 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 39941c2bf08be01220f2eab8b69c25b4303f8179/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.