Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#17759 closed defect (fixed)

ResizeHandle does not work on a dndItem (IE10)

Reported by: towby Owned by: bill
Priority: undecided Milestone: 1.8.9
Component: DojoX Layout Version: 1.9.2
Keywords: Cc:
Blocked By: Blocking:

Description

Using a dojox.layout.ResizeHandle? on a dojo.dnd.Source item does not work in IE 10. The resize handle cannot be used because the onMouseDown event handler of dojo.dnd.Source handles it as a drag start event.

I attached a test page to demonstrate that behavior. In FF or IE < 10, the handle can correctly be used to resize the elements, in IE 10, the handle does not work because the drag is started. This behavior may also occur in IE 11.

Attachments (1)

Dojo.Ticket.17759.Dnd.Resize.Bug.html (2.0 KB) - added by towby 6 years ago.
Test page to demonstrate the resize bug on a dndItem

Download all attachments as: .zip

Change History (12)

Changed 6 years ago by towby

Test page to demonstrate the resize bug on a dndItem

comment:1 Changed 5 years ago by bill

The resize handle cannot be used because the onMouseDown event handler of dojo.dnd.Source handles it as a drag start event.

Hmm, I don't understand why the dnd code is seeing the mousedown event when ResizeHandle? calls eventUtil.stop().

comment:2 Changed 5 years ago by towby

I just tried the testpage again in IE 10. The resize handle actually does work correctly now but the DND container seems to be broken because drag and drop on the nodes doesn't work anymore

Maybe the dnd problem causes the handle to work correctly again because the event isn't intercepted.

And even if the ResizeHandle? calls eventUtil.stop(e) the resize mousedown callback needs to get called before the drag callback for this to take effect, doesn't it? As far as I can remember the situation, the drag callback was executed first.

comment:3 Changed 5 years ago by bill

Milestone: tbd1.8.9
Owner: set to bill
Status: newassigned

OK, I'll fix, and backport to 1.10.3, 1.9.6, and 1.8.9. (This is a regression due to #15185.)

comment:4 Changed 5 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 1f7fa7a46caf2a38ccc797e60d2de1b470d4b1b5/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 5 years ago by Bill Keese <bill@…>

In e2e2f3231d1ae04a8c88ad8b5dc77cef904ff8f5/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 Changed 5 years ago by Bill Keese <bill@…>

In 8ea9cf216f66c258b47aeee82cd7336a3674b746/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:7 Changed 5 years ago by Bill Keese <bill@…>

In 1d6f540864f8d0aaccdc0872ca6169c8087b3e9e/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:8 Changed 5 years ago by Bill Keese <bill@…>

In 0cb644338f29a1a07eeb10ae5aa216dd79742098/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:9 Changed 5 years ago by Bill Keese <bill@…>

In 2c4899617aa12b351ed30659acad75457a74b6a2/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:10 Changed 5 years ago by Bill Keese <bill@…>

In 96e919120979630e760a8f1e4e74f8cb924b7622/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:11 Changed 5 years ago by Bill Keese <bill@…>

In d011c18e5116a65a29c83317335d59e313937792/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.